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1 Definitions

Activities: General activities expected for the project. Detailed updates and information should
be entered under Status Updates once the new project has been submitted.

Category (for Status Updates): Categories are predefined and intended to be general enough to
be used by all groups; when a row in the drop-down list is highlighted a pop-up tip will describe
the general information about the category type. It is up to each group/section/branch to
determine how these categories fit into their requirements. The bold items are required to meet
minimum reporting requirements.

« Administration

» Deliverable

« Deployment

» Development

« Enhancements

» Highlights/Milestones

« Installation/Configuration

« Maintenance

» Meetings/Conferences

» Operations

» Qutreach
* Report

» Support
» Training

Contacts: This is intended for individuals or other contacts to which the project is to be sent
upon completion.

Project: A project can consist of a general project heading, such as “General Training” or be a
specific long term/short term project.

State (for Projects): When entering a new, or editing the status allows a project to be designated
as active, open, ongoing, on hold, or re-opened.

Status Update: This is specific information regarding actual actions taken along the course of
the project. These must have a date associated (can be approximate) to aid the reporting process.

Status Updates are the data queried when generating bi-weekly reports (or any other period of
time).
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Note: Status Updates can only be made to Activities already entered in Program Tracker.

Team: Individuals who are working on the project.

Viewing: These views have a gray colored theme and are used solely for viewing data. This
view can be accessed via the View selection in menu bar. 3

IPlan Summary Report: Contains all the activity formatted like the IPlan.

Status Update Report: Contains the Status Updates that fall between the dates selected in the
date fields. Reports can be sorted in two ways: Date only and Category, then by date.
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2 Getting Started

Note: If the Program Tracker database application is not on your computer Desktop, ask
Nick Perez of the CDEC section to load it.

This is the CDEC window.

%,

About COEC DWR Home

MOST POPULAR LINKS

“# Executive Summary

DEPARTMENT OF WATER RESOURE
California Data Exchange Center

M Query Tools | Precipitation | River Forecast | River Stages/Flow | Reservoirs | Snow | Stations | Weather

Egcger Accessibility ‘Saan:h

@ DWR O California

DOFM Home
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PROGRAM TRACKING

“® Station Search

coiEdbEnEm
“# Daily Data

Tracking The Project Tracking Application is a toel aimed at easing the proce == of

reporting and tracking progress. It is written in java and deployed as a webstart

application, which requires you to accept a certificate upon the initial running of
the program. Documentation for program use can be fo und here:

Program Tracking Documentation

og|

“* Program Tracking

“# Station Locator
»

“® Contact COEC Staff

% Daily Water Temperatures

ANNOUNCEMENTS

~

02/08/2012: Deployed new version of the Program and Activity Status Tracker(PAST). Important new features include: Ability o fiter Status Updates by
category.

RELATED LINKS
# California Cooperative Snow
Surveys

* California Drought
Information

»

¢ E

102/07/2012: Deployed new version of the Program and Activity Status Tracker(PAST). Impertant new features include: Abilty to generate Status Update reports.
hat are fittered by DVWR employee, Activity and Date. Activities now have a Start Date, End Date and Target Date. The IPlan Summary Report is the new template —
all new/existing Activities. Feature in development: Ability to fiter Status Updates by category.

10/21/2011: New Feature added to Program Tracking: Pregram Tracking Application now utiizes a desktop functionality. Internal windows can be minimized and
multiple windows can be viewed at once. The look of the application has been changed to provide a consistent feel, using Liguid LnF.

10/17/2011: New Feature added to Program Tracking: Added requirement to associate an Activity with a DWR organization level.

[09/09/2011: Completed initial consolidation/review of Activities within PTA in coordination with Hydrology Branch program managers.

2. Select the red text ‘Program Tracking’ from the above window.

3. Program Tracker will display the window that you worked on last. You may close all

1. Double-click the Program Tracker icon on your desktop. The below screen will appear.

@l

£3

other windows at this time, and, if you like, close all previously opened PT windows until
you see the below basic Program Tracker window.

PA Jser: gnolan UserType PERVISOR 0

Eile View Tools Help
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3 Adding and Editing

3.1 Add a New Activity
Note — Program Tracker allows for the development of 8 Functional Areas, FAl- FA7
and NA. HAFOO program activity is organized under FA1 — Emergency Response.

1. From the main screen menu bar, select Tools, FloodSAFE Management Tool. The below
Element/Component/Activity View screen will appear.

Element /Component /Activity View

F- e

Functional Area MNew Activity b, )]
B FA1-Emergency Response Organizational Structure:
E CDCF - Climate Data Collection and PrecipitationiRur || - N Ve Vs N oV N
E ?7- DeltaFlood Preparedness, Response, and Recor || Agency by - 3
B E EPR- Flood Operations Emergency Response FloodSAFE Structure: FloodSAFE ID |
= € EPR.DLTA- DWR Delta Flood Emergency Prapare || « Functional Area N eV ™ |<FA> <E\emID|
A FA1 EPR.DLTAD1 - Develop the DWR Delta Fli |1 = -
A FA1 EPR DLTADZ - HAFOO, DSMO & DHCCP | [Activily Name: State: Start Date

A FA1 EPRDLTAD3- Delta EOR (Active ) ||03/o1/2012

A FA1 EPRDLTADA - Delta Levees Special Praje
A FA1 EPR DLTA 05 - Develop Bookend Failura ¢ LargekDats End:Daly
A FA1 EPRDLTA0G - Regional Flood Preparedn 03/01/2012 |DEJ'DU2012 ‘
A FA1.EPRDLTADT - USACE In-Kind Service Ag
C EPR.DWR - Depanrment Statewide Emergency Op
€ EPR.JOC - Jnint Operations Center
C EPR.LOAG - Local Agency Emergency Preparedne
E PM- Program Management
E RTFC - Real-time Flood Conditions, Status and Warni
E RCRF - Reservoir Operations & River Forecasting (RC
E ?7- Updated Hydrology and System Re-operations
FAZ2 - Operations & Maintenance and Environmental Stewards
FA3 - Floodplain Risk Management
FA4 - Flood Protection Projects and Project Grants
FAS - Evaluation and Engineering € Add Team/Contact Member
FAE - Flood Management Planning and Conservation Strated | Togm- Contacts:
FAT - Legis|ative, Budget and Communication
A - NiA

Goal:

Background:

EID LMAME | FRAME | EMAIL | PHOME | ACTIVE EID LMAME | FRAME | EMAIL | PHOME | ACTIVE
870Molan  Gerald ognolan.. 91657 A

_ Submit New Activity J
] i

1. At the above window, select ‘New Activity’ at the top middle of the screen.

2. Determine the next ECA ID # to be used by expanding the Element Grouping (left side of
screen) for the Functional Area to which the new Activity will belong.

Example — if your team agrees that a new activity is needed to capture work being
performed in the area of DWR Delta Flood Emergency Preparedness, you will expand
Element ‘EPR — Flood Operations Emergency Response’, and then expand
Component ‘DWR Delta Flood Emergency Preparedness’.

If, after reviewing the existing Activities under Component ‘DWR Delta Flood
Emergency Preparedness’, your team still feels that a new activity is needed (use
existing activities whenever possible), you will use the next ‘ECA ID number’ in that
section. Per the above window, the next ‘ECA ID number’ is FA1.EPR.DLTA.0S.

3. Complete the sections in the main area of this window and insert the new ECA ID
number in the section ‘FloodSAFE Structure’. Much of the other information may be
gotten from contract Statements of Work.
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3.2 Add a New Agency/Company

1. On the menu bar, select File=Company/Agency for the below window.

LIENCVICOMPanNY) =%
COMPANY_AGENCY_ID COMPANY_AGENCY
92CADepartment of Fish and Game - Stanislaus R Restaration
90 Contra Costa County - Flood Control ‘
43 David Ford Consulting Engineer Inc
323 Dept of General Services
287 Dept of Interior, Sequoia-Kings Canyon
286 Dent of Interior, Yosermite
203 GE| Dept of Interior, Sequoia-Kings Canyon |

3

284 Hewlett-Packard g
303 Kneaner Electric 50

g Mew Companyihgency 4 Edit Company/Agency

New Company/Agency
Company hame
| |
Address
| |
| |
City: State/Province
| il |
Country Zip Code

)

2. To add New Company/Agency, click on the ‘New Company/Agency’ button in the left
middle of the screen.

3. Complete the fields in the lower section and click ‘Submit’.

4. After restarting the program, the newly installed agency/company will be displayed in the
upper window and available for use throughout the program.
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3.3 Add a New Status Update

Note: Status Updates can only be made to Activities already entered in Program

Tracker.

1. On the menu bar, select File>Status Update for the below window.

ALL w) Set Default | Load Default

1D |STA.. MAME
3601 Acti... Budget Tracking: DGS, MNar...
4781 Acti... Contract, GEl Aministration
3761 Acti_. Contract Cost Share - DPL
3641 Acti... Contract: PRISM - DPLAU .
3232 Acli... Contracts and Purchasing
3542 Acti.. DOl Mational Park Service ...
4681 Acti... Forecast-Coordinated Ope
3721 Acti.. HAFOO 10 Reporting
1901 Acti... HP Maintenance Agreement
3582 Acli... Library Maintenance
2143 On... Miscellaneous Administrati...
1882 Acti.. NOAA
3231 Acti... Office Equipment Inventary
1841 On... Packer Contracts
3621 Acti
3546 Acti..
3681 On
1861 Clo...
1564 Clo...
1665 Clo
1662 Clo...
2881 Acti
3044 Acti..
3681 Acti..
1902 Acti
2886 Acti...
1663 Clo

Program Budget
. Project Tracker Development
Travel and Training adrn

UC Berkeley 4600007952
UC Merced (Quality)
UC Merced {Quantity)
UC Merced (Spatial) 46000...
UG Umbrella Confract
. U8 Dept of Agriculture - For...
. USACE Hydrology Modeling
UBBR Agreements
Vehicle Management Progr...
pre-Umbrella, UC Merced

0O00000O000O0o0ooooooooDooooae

SIatiEIPIHIEY

Category:

LAl -
-

comment

Date Range Search:

Search
|le31f2012 | t0|03fﬂlp’2012 | Clear Search

Date Activity Categary | Employee

. Mew Status UpdatE)_ )

Newr Status Update

Entry DateiTirne Activity:

03/01f2012 14:17 | Mo Selection -

Employee: Category:

Maolan, Gerald - -

comments:

Submit Status Upslate

2. Screen sections explained —
a. The left column displays all activities of which you are a team member.

i. Toadd your name as a team member, go to ‘Add Team/Contact Member’
section at bottom of Activity screen

b. The upper part of the right column will display existing updates for whatever
activity(ies) you check in the left column.
c. The lower part of the right column is where you

i. Create New Status Updates, and
ii. Edit existing Status Updates

3. New Status Update
a. Select New Status Update button in upper left of New Status Update section
b. Complete the fields in the lower section and click ‘Submit Status Update’.
c. Select ‘OK’ in the pop-up window
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1. On the menu bar, select File>Activity for the below window.

o > N

Functional Area
B FAT - Emergency Response

E CODCF - Climate Data Collection and Precipitation/Rur
E 77 - Delta Flood Preparedness, Response, and Reco
2 E EPR- Flood Operations Emergency Response

B € EPR.DLTA- DWR Delta Flood Emergency Prepare

A FA1EPR.DLTAD

- Develop the DWWR Delta Fli
A FA1EPRDLTADZ-
A FA1EPRDLTADZ-
A FA1.EPR.DLTA.D4 -
A FA1EPRDLTADS-
A FA1EPR.DLTADG-
A FA1.EPR.DLTAOT -

HAFOQ, DSMO & DHCCP
Delta EOP

Delta Levees Special Proj
Develop Bookend Failure ¢
Regional Flood Preparedn
USACE In-Kind Service Ag

C EFR.DWR - Department Statewide Emergency Op
C EPR.JOC- Joint Operations Center
C EPR.LOAG - Local Agency Emergency Preparedne

=

BB H

E PM- Program Management

E RTFC- Reakime Flood Conditions, Status and Warni
E RORF - Reservoir Operations & River Forecasting (RC
E 77 - Updated Hydrology and System Re-operations

FAZ - Operations & Maintenance and Environmental Stewsards
FAZ - Floodplain Risk Management
FA4 - Flood Protection Projects and Project Grants

FAS - Evaluation and Engineeting §
FAG - Flood Management Planning and Congervation Stratec

FAT - Legislative, Budget and Communication

A - DA

Element /Component /Activity View

( New Actvity X )
Organizational Structure:
Crgeney ¥ X X ¥ b
FloodSAFE Structure: FloodSAFE ID D
. Functional Area v\\ \‘_ D 'm‘
Activity Mame: State: Start Date:
Target Date End Date:
oozmz || oz |
Goal:
Background:
Add Team/Contact Member J
Team: Contacts:

EID | LMAME | FNAME | EMAIL

PHONE | ACTIVE EID' | LMAME | FNAME | EMAIL | PHONE | ACTIVE

870Molan  Gerald gnolan... 91657.. A

Submit Newr Activity J

From the left column, double-click on the activity to be edited.

Select ‘Edit Activity’ at the top right portion of the screen.

Edit the fields, as necessary.
To add Team/Contact Member —
a. Select ‘Add Team/Contact Member

b. Select agency with which the person is associated

Cc. Select ‘Add to Team’ or ‘Add to Contact’ and close window

To delete Team/Contact Member —

a. Right click on name of team member or contact
b. Select ‘Delete Row’
Click ‘Submit Changes to Activity’.

Select ‘OK’ in the pop-up window
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1. On the menu bar, select File>Status Update for the below window.

T

w
m
i

1D |3TA.

4781 Acti
3761 Acti
3641 Acti
3237 Acti
3547 Acti
4681 Acti

3546 Acti
3581 On
1561 Clo
1564 Clo
1565 Clo

O00000000000000000000000O0oOOO

3601 Acti..

3721 Acti..
1901 Acti..
3582 Acti..
2143 On...
1882 Acti..
3231 Acti..
1841 On...
3621 Acti..

1562 Clo..
2881 Acti..
3544 Acti..
3681 Acti..
1902 Acti..
2886 Acti..
1562 Clo..

L ALL ) Set Default| Load Default

MAME
Budget Tracking: DGS, Mor.,
Contract, GEl Aministration
Caontract: Cost Share - DPL
Cantract: PRISM - DPLANL
Contracts and Purchasing
DOl Mational Park Service
Forecast-Coordinated Ope
HAFOQ |0 Reparting
HP Maintenance Agreement
Library Mairtenance
Miscellaneous Administrati...
HOAR
Office Equipment Imientory
Packer Contracts
Program Budget
Project Tracker Development
Travel and Training adm
UG Berkeley 4600007352
UC Merced {Quality)
UC Merced {Quantity)
UG derced (Spatial) 46000...
UG Umbrella Contract
US Dept of Agriculture - Far...
USACE Hydrology Modeling
USER Agreements
Wehicle Management Progr...
pre-Umhrella, UC Merced

Date Range

|01131;2012 | 1u|namlfzn12 |

Date

Category, Search:

Search
Al -
- J

Clear Search

Comment Category | Employee

( ew status Updata )

Entry DatesTime

New Status Update
Activity:

03/01/2012 14:17

AW

| o _an Selection

Employee:

Categary:

{Nolan, Geral

(€

v

Comments:

Submit Status Update

From the left column, double-click on the activity to be edited.

Make necessary changes.
Click ‘Submit Status Update’.

N o gk~ D

Select ‘OK’ in the pop-up window

In the upper part of the screen, double-click on the status update to be edited

In the lower part of the screen, select the ‘Edit Status Update’ button.
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4 Activity Deliverables

4.1 Adding a New Activity Deliverable

1. Go to File->Activity Deliverables

LALL
1o STATE
3601 Active
4781 Active
3761 Active
3641 Active
3232 Active
3542 Active
4681 Active
3721 Active
1401 Active
3682 Active
2143 0ngoi
1882 Active
3231 Active
1841 Ongoi
3621 Active
3546 Active
3581 Ongoi..
14661 Closed
1564 Closed
1565 Cloged
1362 Closed
2881 Active
3544 Active
3681 Active
1902 Active
2886 Active
1663 Closed

-
|

MNAME
Budget Tracking: DGS, Mor...
Contract, GEIl Aministration
Cantract: Cost Share - DPL
Contract PRISM - DPLAL .
Contracts and Purchasing ..
DOI, Mational Park Service
Forecast-Coordinated Ope
HAFQO 10 Reporting
HP Maintenance Agreement
Library Maintenance
Miscellaneous Administrati
NOAS
Office Equipment Inventary
Packer Contracts
Program Budget
Project Tracker Development
Trawvel and Training adm
UG Berkeley 4600007952
UIC Merced (Quality)
UC Merced (Quantity
UG Merced (Spatial) 46000...
U Umbrella Contract
LIS Dept of Agriculture - Far.
USACE Hydrology Madeling
UISER Agreements
Wehicle Management Proar...
pre-Umbrella, UC Merced

Activity Deliverable List
Activity Deliverables

DELIVERABLE_ID DELIVERABLE_..| TARGET_DATE =~ START_DATE END_DATE MODIFIED_DATE | TARGET_DATE_.

F TS r——— F = —r———
. # . J
Activity Deliverahle

Start Date End Date Target Date:

gymyemz ||| [pajoraoiz n3jo1/z012 | Annust event

Deliverable Description:

’ Submit New Activity Deliverable

4.2 Editing an Existing Component Deliverable

4.3 Adding/Editing a Component Deliverable Milestone
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5 Reporting

5.1 By Individual

Note: The reports by individual are used by Administrative staff members to support
their presentations at the Admin and Support Staff meetings.

1. On the menu bar, select View>Browse Activities for the below ‘Browse and Report on
Activities” window.

General Report Status Update Report Filter:
( § Status Update Report ) Employee F\Iter) C Load All Activities @ Active O Closed
DD |uzf17;2t|12 ‘ to |ua;uzfzu12 | [ cateqory Fiter (%] Show Sub Activities ) Gngaing () On hald

Qrganization: Show Activities at or below current selected Org level
__ The Resources Agency v\‘ Department v\‘ \‘ \‘ \‘ y
SELECT D STATE |FLOODSA MNAME PROJECT_GOAL PROJECT. LEAD | TARGET_ . START_D.. END_DATE

: 3601 Artive FA1.PMA.. Budget Tracking: DGS, Morth Coa... Stop auto payment being withdraw... This cost-... Molan, Ge...

: 4781 Artive FA1.PMA.. Contract, GEl Aministration Administer GEI Contract: budget, i... Administe... Mountioy, ..

D 3761 Artive FA1.PMA.. Contract CostShare - DPLAMSG... Share data from the USGS Waters... HAFOO H... Lek, Boone

D 3641 Artive FA1.PMA.. Contract PRISM - DPLAU of Oreg... Support DPLAS contract #46-8729 . This inter.. Lek, Boone

D 3232 Active FA1.PMA.. Contracts and Purchasing Support To ensure the Hydrology and Floo... Acquiring ... Molan, Ge..

D 3542 Active FA1.PMA.. DOl National Park Service (Yose.. Establish and maintain a supporti... Section 2.. Molan, Ge.

D 4681 Active FA1.PMA.. Forecast-Coordinated Operations ... Anticipated benefits resulting from ... The Forec... Molan, Ge..

: el Active FATPMA. . HAFOO 10 Reporting Create monthly HAF OO budget ativ... Since the i.. Molan, Ge.

: 1801 Active FATPMA.. HP Maintenance Agreement Provide maintenance services fro.. HP COEC.. Molan, Ge.

: 3582 Active FATPMA_. Library Maintenance Establish and maintain shared, se... Personnel.. Molan, Ge.

: 2143 Ongoing  FAT.PMA.. Miscellaneous Administrative Sup... Provide Suppaort for HAF OO Staff Required ... Kitts, Leesa

: 1882 Active FATPMA - NOAA Contract with NOAA, as necessary, . The Mem_. Maolan, Ge

: 3231 Active FA1PMA . Office Equipment Inventary Achieve and maiintain accurate inv.. SAP inven . Molan, Ge

: 1841 angoing FA1PMA . Packer Contracts Setupindividual packer contracts | Contracts . Malan, Ge

: 3621 Active FA1PMM. . Prograrm Budget Develop and maintain a budgetth . Currentb . Hinojosa,

: 3546 Active FA1PMA . Project Tracker Development Developrment of a server and/orw. Project Tr.. Malan, Ge

: 3581 angoing FA1PMA . Travel and Training adm Provide timely, professional assist . Thisis an. Kitts, Leesa

: 2881 Active FA1PMA . UC Umnbrella Contract Place all activities conducted with . DWR/Hydr__MNalan, Ge

: 3544 Active FA1PMA_ . US Deptof Agriculture - Forest Ser.. Establish and maintain a supporti Title 16 L. Molan, Ge

: 3681 Active FA1PMA . USACE Hydrology Modeling Contract #4600009431 is Phase 1. The curre.. Talanki, 5

: 1802 Active FA1PMA . USBR Agreements Prawide reimbursement to Federal . Contract#. Maolan, Ge

: 2886 Active FA1PMA_ . Wehicle Management Program Achieve total accountability, update . At assum.. Malan, Ge

Note: This window displays all activities of which you are a team member and/or

contact. To add your name as a team member, go to ‘Add Team/Contact Member’

section at bottom of Activity screen.

Right click mouse and choose ‘Select All’.

Updates Report’ and ‘Browse and Report on Activities’.

10

In top section of the above window, select ‘Status Update Report’.

Place cursor over the main section of the window where the activities are displayed.

Move the resulting Status Updates Report window so you can see both windows — ‘Status
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6. On the window ‘Browse and Report on Activities’, uncheck any activity for which you
took no actions during the reporting period (see dates just below button ‘Status Update

Report).

7. Close ‘Status Update Report’

8. Run an updated ‘Status Update Report’.

i
9. Print final report using the % icon in the top left portion of the Report.

10. If necessary, take the below actions.
a. Add omitted Status Updates

iv.

Vi.

Vii.

Leave open the ‘Browse and Report on Activities” window.
Select File >Status Update from the same window.
Complete any necessary status updates.

Close the Status Update window. This will reveal the ‘Browse and Report
on Activities’ window.

Place cursor over the main section of the window where the activities are
displayed.

Right click mouse and choose ‘Refresh Table’.

Repeat steps 4 thru 6 above.

b. Remove activities for which you don’t share reporting responsibilities

Vi.
Vii.

viii.

Leave open the ‘Browse and Report on Activities’ window.
Select File>Activity from the same window.

Highlight the activity from the left column for which you don’t share
reporting responsibility.

Select the button ‘Edit Activity’ at the upper right part of the window.
In the section ‘Add Team/Contact Member’
1. Highlight your name and right click.
2. Select ‘Delete Row’
Select bottom button ‘Submit changes to Activity’.
Select ‘OK” in pop-up window.

Repeat steps 8c thru 8g, as necessary.

11
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5.2 By Activity
5.3 By Component Deliverable
5.4 By Section
5.5 By Branch

12
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6 Resources

“Program Tracking Documentation” California Department of Water Resources, 2008

13



